Question

Writing to MDA Data Objects from Rules Engine: No access to custom tables

  • 8 August 2019
  • 5 replies
  • 88 views

Userlevel 4
Badge
Good Morning-



Our new SVP of Client Success has some reports he needs built, however the data he’s asking for in one report come from multiple MDA tables and from SFDC. I’m trying to populate a new MDA table from the Rules Engine, however the custom MDA table is not showing up when I choose “Load to Gainsight Object”.



Why would this be happening?

Thanks!

-Jim

from the Rules Engine, however the custom MDA table is not showing up when I choose “Load to Gainsight Object”.


5 replies

Userlevel 7
Badge +1
Did you set the permissions to allow writing to that object? Details here: https://support.gainsight.com/Rules_Engine/Admin_Guides/Use_Rules_to_Load_to_SFDC_Object_or_Gainsight_Object#Permissions

Objects won't show up until you enable them and the specific fields in the object you want to make available for rules upsert.

Userlevel 4
Badge
Confused: Why would I have to give myself permission to write to a custom object that I created? What's the origin of this logic? Is this just legacy logic that will be deprecated in the near future?

Userlevel 7
Badge +1

With the Gainsight NXT version, we don’t need to provide permissions to the MDA Objects. The Objects which are created in MDA, by default we can choose in Rules Action Part. No need for Permissions.

Thanks.

Userlevel 7

Confused: Why would I have to give myself permission to write to a custom object that I created? What's the origin of this logic? Is this just legacy logic that will be deprecated in the near future?
 

Yes James, this is a legacy logic. The idea way for admins to have an indirect way to control any damages caused by any newer/inexperienced admins. We did away with it in NXT. 

For SFDC however, this is still the case and quite a lot of our customers have multiple admin scenarios I mentioned above. 

Userlevel 7
Badge +2

@james_whitehead did you get a chance to view the comments here.

Reply