Solved

Issues with tokenized comments in a rule

  • 10 July 2020
  • 7 replies
  • 141 views

Userlevel 3

Has anyone experienced an issue when tokenizing rule comments?  I have been creating some new scoring rules and have noticed that when I run a report on the Unified Scorecard data source, my comments are not updating and some of the comments have added on verbiage which I did not include in my rule comments.  Here are a few examples, looking for guidance or if anyone else has faced this issue...thank you in advance for any advice!

Comments in the rule
​​​​​
Report showing 83 days ago which is not in the rule?

 

icon

Best answer by ablnsj 13 July 2020, 17:47

View original

7 replies

Userlevel 6
Badge +4

@ablnsj - I would check the CS Start Date for that record and confirm there is no other information in the field for that particular record. If it’s a date field, there should be nothing else but the data. However if it’s a text field which requires CSM entry, they could have included more data in that field. 

 

For other accounts where the scorecard comment is not updating, I would suggest you follow the data and make sure the rule ran correctly for those accounts. It’s possible that they are getting filtered out some how. A good way to test a rule on a particular account is to filter down to just that account so you’re not running the rule for the entire account list. 

Userlevel 5
Badge +3

Hi @ablnsj 

It’s weird. The comments should come based on the comments on how we set up in the Rule Action Part comments section. Can you please check the CS Start Date value for the “Discovery” account where you have shown in the screenshot.

And for a best practice, every time filter for some accounts in the rule fetch task filter condition and do Test Run. Based on the rule result we can proceed with further steps.

 

Thanks.

Userlevel 3

Hi @ablnsj ,

There is no known issue with this behavior. As @phani_kumar  suggested please check CS Start Date value for the “Discovery” account which you have shown in the screenshot. If it is a proper date field, then please raise a support ticket. This helps us to analyze further. 

Thank you. 

Userlevel 3

@phani_kumar  and @tulasi_andukuri  

I have GS Support looking into this already, but thought I would post here to see if anyone had experienced something like this before. 

What I am trying to achieve in this rule is to ensure that we do not include new customers in the health score until 180 days after the customer is assigned.  Shouldn’t my rule comments p/u only my tokenized comments?  I am not sure where the 83 days is coming from since it is not in my tokenized comments?  I did ensure it is the correct start date and the data behind it should just be a date not the days.

 

Thank you  

Userlevel 3

Thanks everyone, it has been reviewed by support and it came back that even though this is a new rule I have created with new comments, when you have a filter in the past if there is an exiting rule in place it will pick up those comments as well and not just the rule comment from the new rule.  

Userlevel 6
Badge +4

That’s a bit of strange behaviour. I have seen comments get appended at the end but I’ve never seen it get added in the middle of a comment. Great find and thanks for sharing the solution from Support.

Userlevel 7
Badge +2

Has anyone experienced an issue when tokenizing rule comments?  I have been creating some new scoring rules and have noticed that when I run a report on the Unified Scorecard data source, my comments are not updating and some of the comments have added on verbiage which I did not include in my rule comments.  Here are a few examples, looking for guidance or if anyone else has faced this issue...thank you in advance for any advice!

Comments in the rule
​​​​​
Report showing 83 days ago which is not in the rule?

 

@ablnsj I heard this got solved with the help of our support team. Please let us know if you need help. 

Reply