header
Solved

Reports dont show null data


Userlevel 1

I am trying to make a report to show if an account has had a timeline email forwarded to it. 

right now the report only shows accounts where the answer is “yes”. I need accounts without the timeline entry to show null or 0 or blank and not just be filtered out of the report

icon

Best answer by rakesh 16 June 2020, 11:01

Hi @TheDataSherpa,

If you are using a Data designer’s Dataspace, it is even easier to handle. You can directly do the join which @phani_kumar  demonstrated in the Data Designer as well. 

If it is SFDC dataspace, you can leverage load to SFDC objects to load to the underlying SFDC object (SFDC dataspaces are virtual, not real objects). Happy to help you more here! 

View original

10 replies

Userlevel 7
Badge

Hi, have you seen this article on identifying an absence of data using rules?

Userlevel 1

That article is good but I get stuck at the last step because I need the result to load to a dataspace I made.

Userlevel 4

unfortunately this just gives us the data - we cannot have a report that shows all customers and a 0 if they do not have an activity loaded.   I would have thought that in the data designer a “pivot” option would be available just as it is in bionic rules (which we do use currently).  Basically a left join and include all data in the report with a count of what we are looking at against each account.

Userlevel 6
Badge

Hi @TheDataSherpa 

If I understood your issue correctly, the report which you created was using one Custom Object, right?

If yes, how the data is populated in that object? If you are using Rules to populate the data, maybe in your merge task you selected the option get the “Retain common records from both datasets”. so instead of that, please choose the “Retain all records from left dataset”.

 

And the Left object should be your Account Object or Company Object and the Right Object should be your Timeline Object.

Screenshot:

So that you will get all your Accounts (Left Object) along with the records which are matched in the Right Object.

 

Please try this and let us know if that works for you or not.

 

Thanks.

Userlevel 1

phani_kumar,

That is how we set up the merge, thanks for confirming we did it in a logical way, the issue is getting this data loaded to a dataspace where I can use it to create a report. That doesn’t seem to be possible.

Userlevel 6
Badge

Hi @TheDataSherpa ,

So means your rule was not loading to the data to the Target Object where you want to use that to create a report. Is that correct? And if possible could you please provide some more details about your issue(with screenshots)

 

Thanks.

Userlevel 1

that is not correct, the target object is a dataspace which does not show up as an option for my rule, therefore, there is no where for me to load the data to

Userlevel 6
Badge

We don’t have an option to load the data to Dataspace Object(Target Object) using Rules.

Userlevel 6

Hi @TheDataSherpa,

If you are using a Data designer’s Dataspace, it is even easier to handle. You can directly do the join which @phani_kumar  demonstrated in the Data Designer as well. 

If it is SFDC dataspace, you can leverage load to SFDC objects to load to the underlying SFDC object (SFDC dataspaces are virtual, not real objects). Happy to help you more here! 

Userlevel 7
Badge

@TheDataSherpa did you get a chance to try with the Data designer. Let us know if you need any help.
Here is the article refers to Data Designer. 

Reply