header
Solved

How do I keep dialog bars fixed when you scroll?


Userlevel 3
I built out an engagement that is a dialog and is set as a bar at the bottom of the page. When the page is first loaded, it is at the bottom of the browser. However, when I scroll, the banner moves with me. I expected the banner to stay fixed to the bottom of the browser window. Is there an easy way to solve for this?

icon

Best answer by michael_sweeney 22 August 2019, 17:29

@ajrufer Good news... This has been fixed in production



View original

10 replies

Userlevel 5
@ajrufer are you able to share a quick video/ screenshot just for an accurate understanding of your ask?

Userlevel 7
Badge

Welcome to the Community @ajrufer ! When you have a chance, be sure to Subscribe to the PX Discussions and PX Idea categories, so you can stay up-to-date on PX conversations and product tips from the Community!
 

Userlevel 3
@harshibanka - Absolutely, I created a video. I'll send it to you via email since I don't have a link for it.

Userlevel 7
Badge
Hi Amanda @ajrufer ,

My name is Mike and I am with the PX Support team. I just wanted to reach out and let you know we are currently looking into the issue you have reported. What I have noticed is this is happening when the Overlay is unchecked.



You can check this box for now if it fits your use case and I will let you know more while we investigate this behavior.

Thanks,

PX Support



Userlevel 5
Hey Amanda, I'd understand if you did not want to use an overlay because you are using a Bar for a reason so as to not blcok the users.

Like Mike mentioned, he will investigate this behavior and revert.

Userlevel 3
Thank you @michael_sweeney for looking into this for us. @harshibanka i hit the nail on the head that we'd like to use the bar in a less intrusive way but I appreciate the secondary option.

Userlevel 7
Badge
Quick update here guys. This has been accepted as a bug and engineering team is working to have this corrected.

Userlevel 5
Thanks Mike.

Userlevel 7
Badge
@ajrufer Good news... This has been fixed in production



Userlevel 3
Awesome, I tested out our banners and it's working perfectly now! Thank you @michael_sweeney, I really appreciate you and the engineering team working so quickly on this!

Reply