header
Solved

Do not Check 'Map Gainsight Standard Fields' by Default From Surveys

  • 1 February 2019
  • 8 replies
  • 241 views

Userlevel 7
Badge
If you publish a Survey (2.0) to a Program, the Program settings under the Participant configuration 'Map Gainsight Standard Fields' is checked by default. This is not a setting I have ever had to worry about in creating a Program from scratch, but it has twice now negatively impacted the experience of building a program from surveys.

1) Using a Powerlist - During testing in our QA environment, I was unable to select a powerlist due to this setting. It required GS support to identify that flag as the cause. Removing the flag then enabled me to select a Powerlist.

2) Email Preview in Program - Before launching in our Prod environment, using a CSV upload, I COULD NOT preview an email that either embedded a survey question or linked to a survey. Previews failed to load and and sending tests to myself were unsuccessful (even though on screen messaging confirm a test was sent). This only impacted the emails within the program that pointed to a survey. 4 other emails in the program were previewed without issue. While on GS chat support, I realized what gave me trouble previously and checked off the Standard Fields setting, and VOILA - emails could be previewed.

No error messages presented themselves, and this setting was not indicated anywhere in the guidance of a Program or a Survey Model. Incredibly frustrating having a hang up like this without any indication as to what the problem is.

icon

Best answer by abhishek_sivaraman 13 April 2019, 02:11

Hi All, We are removing this default check done as part of program configuration from the upcoming release. You should not face this issue anymore.



View original

8 replies

Userlevel 3
Badge
Thank you for this note - I was just trying to figure out why I could not see powerlist as an option anymore!

Userlevel 7
Badge +1
Thanks for posting.

In addition to that, I have seen a third problem while uploading a CSV.

This was a simple survey email that needed to go out and a CTA getting created in the JO after the email was sent out. However, because this checkbox was checked by default, the system was expecting Company id instead of SFDC account id. This was resulting in failure at the CTA step.

Userlevel 6
Hi All, We are removing this default check done as part of program configuration from the upcoming release. You should not face this issue anymore.

Userlevel 7
Badge
Hi All, This is fixed and pushed to latest releases. Please let us know if you need any help.

Thanks for posting.

I am getting the “Failed to load preview for this participant. Please try again.” error and cannot figure out why since the default check of 'Map Gainsight Standard Fields' seems to no longer exist. Does anyone know why this would happen?

Userlevel 7
Badge +1

I am getting the “Failed to load preview for this participant. Please try again.” error and cannot figure out why since the default check of 'Map Gainsight Standard Fields' seems to no longer exist. Does anyone know why this would happen?

This is can be caused if there the participant fails to fall into an email variant filter and the setting for default is disabled. Or the participant is missing a value for a tokenized field on the email template and a value is required.

Thanks for the quick reply. I am still perplexed what the issue is because the “heads up” email previews and sends without any issue when the “survey” email does not. I removed all tokens from the survey email template and checked the participants to ensure my one test participant appears. No apparent issues...

Userlevel 7
Badge +1

Since it is a survey, if you are querying a Gainsight object to build the participant list you’ll want to use Gainsight Standard Field mapping

Reply