UI issue on column-line chart

  • 1
  • Problem
  • Updated 8 months ago
  • In Progress
  • (Edited)
We have a column-line chart where all of the data points of the line are 100%. However, the line appears alongside the bottom (x-axis) of the chart, which visually looks like all data points are 0%: 



Expanding the date range exposes non-100% values and the line adjusts, such that data points of 100% are above the columns and others dip lower. Intuitively, if all of the line data points are 100%, the line should still appear above the columns.

Interested to hear others' thoughts.
Photo of John Nunziati

John Nunziati

  • 250 Points 250 badge 2x thumb

Posted 8 months ago

  • 1
Photo of Idupulapati Tharuni Sai

Idupulapati Tharuni Sai, Employee

  • 220 Points 100 badge 2x thumb
Hi John,

The above image you are referring to is having dual y-axis enabled and "Transaction Approval Rate(%)" legend data points corresponds to right-hand side of the y-axis. As initial data points itself starts with 100 hence it is visually looks like 0%.
You can turn off  dual y-axis from chart settings icon, then data points with 100% will appear above the columns.


Thanks,
Tharuni.
Photo of John Nunziati

John Nunziati

  • 250 Points 250 badge 2x thumb
Hi Tharuni,

Turning off dual y-axis may fix the issue for that use case but most of the time we need dual axis on, as the the data points from our two sources usually do not align. Turning off dual y-axis for one of our typical customers in this report results in something like this: