Scorecard Comments coming through with formatting data in a rule

  • 1
  • Problem
  • Updated 2 months ago
  • Solved
I am creating a rule that will copy the current Scorecard Value and Scorecard Comments to a Milestone just before the customer moves into a state where a new Scorecard takes effect.  This way we can see what the Scorecard Value/Comments were at the time of a stage change.

I am merging the Comments field with the MAX Score from the Scorecard Fact Table.

The rule is working except that the Comments field is displaying a lot of formatting characters rather than just the comment text:

Photo of Jeff Kirkpatrick

Jeff Kirkpatrick, Champion

  • 25,662 Points 20k badge 2x thumb

Posted 2 months ago

  • 1
Photo of Dan Ahrens

Dan Ahrens, Official Rep

  • 25,036 Points 20k badge 2x thumb
Hi Jeff, what does the source data look like? The code seems to point to an embedded table (along with other formatting code). 
Photo of Jeff Kirkpatrick

Jeff Kirkpatrick, Champion

  • 25,662 Points 20k badge 2x thumb
It's manually entered.  The only thing I can think is that someone is entering it into a WP and copy/pasting into the comments field - but it seems odd that almost all of these accounts (with different CSMs) had the same situation. (there was only one account that did not have the formatting code)

The other commonality is that these are all comments that were entered when the customer was on a different scorecard, but it's a measure that is shared across two scorecards.  I ran this report post-scorecard change.

NONE of the CSM Sentiment score comments for accounts that still are on the original scorecard are exhibiting this behavior.  Only these that were moved to a different scorecard.
Photo of Dan Ahrens

Dan Ahrens, Official Rep

  • 25,036 Points 20k badge 2x thumb
We might be in support territory here, Jeff. They will probably be able to determine in your org where that markup text is coming from.
Photo of Jeff Kirkpatrick

Jeff Kirkpatrick, Champion

  • 25,662 Points 20k badge 2x thumb
Yes I opened a support ticket thanks!