Owner Field not populating in CTA creation

  • 1
  • Question
  • Updated 23 hours ago
  • Answered
Hello, I am trying to create a rule by merging the GS Relationship and Timeline. I've pulled in the CSM ID, CSM Name, and Author ID fields, but nothing is appearing under the Owner Field section in the Merge. They're visible under the Criteria section though. Could someone clarify expected behavior? Thanks!
Photo of Diana Luo

Diana Luo

  • 972 Points 500 badge 2x thumb

Posted 3 weeks ago

  • 1
Photo of Brent Clark

Brent Clark, Employee

  • 100 Points 100 badge 2x thumb
Are you adding the CSM ID to the Dataset that is fetching the Relationship data?  I did this and added all three CSM IDs that were available (GS Relationship, Account and Customer Info).  These were all available to select in the Owner Field.
Photo of Lila Meyer

Lila Meyer, Official Rep

  • 17,140 Points 10k badge 2x thumb
Hi Diana, Please let us know if you're good here, or need any additional help! Thanks :)
Photo of Pele

Pele

  • 2,464 Points 2k badge 2x thumb
I think this is happening because your merge has the CSM's GSID as opposed to the CSM's SFDC User ID (happens to me all the time). To have CSM be available in the Owner Field (for either Account or Relationship), you'll need the Salesforce User ID. It's pretty easy to tell which is being pulled into the rule– preview the dataset where you're pulling in CSM ID and ensure that it's an 18 digit ID (the GSID, the one you don't want, will be much longer, 36 digits I think.) 
Photo of Diana Luo

Diana Luo

  • 972 Points 500 badge 2x thumb
Hi all, this appears not to have worked, so I'll submit a support ticket. Thanks!
Photo of Diana Luo

Diana Luo

  • 972 Points 500 badge 2x thumb
This one's all set, thanks everyone!