Error importing CSV file (fields unrecognized)

  • 1
  • Problem
  • Updated 4 weeks ago
  • Solved
Has it shows the below image i ́m having some issues to import CSV file.
GainsSight can ́t recognize my CSV fields.

I ́m almost sure that my CSV file ins ́t right, but all i did was export my xlsx file to a CSV and imported to GainSight.
Photo of Ricardo

Ricardo

  • 390 Points 250 badge 2x thumb

Posted 4 weeks ago

  • 1
Photo of Kunal Bhat

Kunal Bhat, Employee

  • 778 Points 500 badge 2x thumb
Hi Ricardo,

I can see that you're using the semicolon as the separator here. When importing data from data management, the file needs to be a comma-separated CSV or the fields won't be inferred correctly.

You could try again after replacing the semicolons with commas. Bear in mind that this route is only valid for files up to 1 MB in size.

Alternatively, you could also explore our S3 connector or the Bulk API channel to load data into Gainsight where you have the option to specify the semicolon as the separator.
Details about those routes can be found here:
S3 Connector
Bulk API


It is also highly recommended to make sure all fields are quoted to avoid data anomalies. 


Hope this helps!


Thanks,
Kunal