Bionic Rule Not Pulling Specific Opportunity But Custom Rule Is

  • 1
  • Problem
  • Updated 1 year ago
  • Solved
I created a Bionic Rule to first fetch data from the Opportunity object in SFDC and then to transform it and upsert into a custom MDA.

I noticed an issue when the 'Amount Closed' upserted into the MDA from the Opportunity object was not matching the amount from a report in SFDC . After some investigation, I noticed that there was one specific Opportunity not being pulled in called 'Upgrade - New Group Subscription'. As far as I can tell, it is still being marked in SFDC just the same as other Opportunities that are being fetched using the bionic rule. 

Furthermore, if I run a custom rule to fetch data from the Opportunity object using the same exact parameters and then upsert into the custom MDA object, I am able to pull 'Upgrade - New Group Subscription' in from SFDC and load to MDA just fine.

Not sure why the bionic rule is not allowing this? I have the same fields in the 'Show' section and the same Filters. I would assume that the Transformation task of the bionic rule is somehow causing this one opp to not be included..but my understanding was that the Fetch task should pull in all the targeted data and then the transformation would act on that data. So not sure why this would cause it to be filtered out.

Any help on this would be much appreciated! I have tried multiple different variations of the bionic rule and still not able to get that opportunity to load to the MDA object. 
Photo of Manmeet Dosanjh

Manmeet Dosanjh, Champion

  • 4,106 Points 4k badge 2x thumb
  • Confused

Posted 1 year ago

  • 1
Photo of Denise Stokowski

Denise Stokowski, Official Rep

  • 12,314 Points 10k badge 2x thumb
Manmeet -
This does sound strange.  Can you open a ticket with support@gainsight.com?  
Photo of Manmeet Dosanjh

Manmeet Dosanjh, Champion

  • 4,106 Points 4k badge 2x thumb
Sounds good, thank you!
Photo of Nitin Pawar

Nitin Pawar, Employee

  • 372 Points 250 badge 2x thumb
Hello Manmeet,
Thanks for raising the issue. We have identified the root cause for this issue and fix is already being planned to be deployed. 
There are no changes required from your side on this. 

This issue was caused by  the special symbol " – " in the value "Upgrade – New Group Subscription". This a symbol is different from normal " - ". We have now added encoding support to address this issue. 

We will update you back on the support ticket once it gets deployed so that you can verify if it has fixed the issue. 
Photo of Manmeet Dosanjh

Manmeet Dosanjh, Champion

  • 4,106 Points 4k badge 2x thumb
That's awesome! Thank you for the support!