Solved

Why can't I edit Data Type in a MDA object?

  • 10 October 2016
  • 4 replies
  • 47 views

Userlevel 5
I have just created an object in the MDA Data Management section, based on a .csv. And the system has automatically set-up some default data types, many of them Boolean instead of number, and I've realized that only after the object was created. Now I need to change the type, but I cannot do that. So I have to send a ticket to delete this object and start all over again.
icon

Best answer by steve_davis 1 March 2017, 22:40

"But if MDA is redshift enabled and data is already loaded at least once, it is not suggested to change the data type." John, your MDA is redshift enabled 😞
View original

4 replies

Userlevel 2
Hi Cristina,

We can't change the data type if there is data in that object. We can only change data type of a field if there is no data in the object. Once the data is cleared from the object, we should be able to change the data type.

If there is no data in the MDA object, please follow the below steps to change the data type:
  • Navigate to the object which you wanted to edit through, Administration > Data Management > click on the object
  • In the schema screen, you should be able to see a pencil for each column under 'Actions'
  • Now click on the pencil for the column you want to edit, and change the data type. Now click on update which should update the schema successfully.
But if MDA is redshift enabled and data is already loaded at least once, it is not suggested to change the data type.

Thanks,
Phanindra
Userlevel 5
The strange thing is that yesterday when I created the new object I couldn't edit the data type, although the object was EMPTY. But today is editable. Is it that maybe just after creating the object I can't change the data type?
Userlevel 5
Badge
Even if you remove data, which i did today, the Data Type cannot be edited. I was just told by Gainsight Support that you have to create a ticket to have the field deleted. Burdensome.
Userlevel 7
Badge
"But if MDA is redshift enabled and data is already loaded at least once, it is not suggested to change the data type." John, your MDA is redshift enabled 😞

Reply