Solved

Can you write data from the "Usage Data" object back to an MDA table for calculations?

  • 1 March 2017
  • 6 replies
  • 82 views

Userlevel 3
  • Gainsight Rookie
  • 54 replies
We need to perform simple calculations ((X + Y * Z) * 100) on data that is stored in the Usage Data object.  We've been able to use calculated fields in the rules engine to write short-term and long-term moving averages back to the Usage Data object, but no matter what we try we cannot write those same values to an MDA table (where we need it to perform additional calculations on).  Is there some limitation we need to be aware of, and more importantly a way to do what we need?
icon

Best answer by dan_ahrens 2 March 2017, 00:10

Hi kclark - in the fall we released the capabilities to perform field level calculations on MDA objects. We had a lot of stuff in the fall release, and this was a smaller feature so it might have gotten overlooked. Check this support article out: https://support.gainsight.com/Product_Documentation/Data_Management_and_Integrations/Managing_Data_I...

The simple calculations that you describe above would definitely be supported using this functionality.
View original

This topic has been closed for comments

6 replies

Userlevel 6
When you are attempting to write these back to an MDA table, what issue are you running into?  If you have an MDA table that is "writeable" via the Rules Engine, you should be able to update there.  If the screenshots are sensitive, let me know and I can pass along my email address.

Thanks
Userlevel 7
Badge
Hi kclark - in the fall we released the capabilities to perform field level calculations on MDA objects. We had a lot of stuff in the fall release, and this was a smaller feature so it might have gotten overlooked. Check this support article out: https://support.gainsight.com/Product_Documentation/Data_Management_and_Integrations/Managing_Data_I...
The simple calculations that you describe above would definitely be supported using this functionality.
Userlevel 3
The same rule is set to load the Usage Data object (which works perfectly) and an MDA table.  The issue is that no data is written to the MDA table even though the rule executes successfully.  I would attach a screenshot of the MDA table, but it's blank.

I would be happy to show you the various rule(s) we've tried, and the MDA table we've built.  At this point I'm looking for anyone who can help me troubleshoot the root cause of the issue so that we can continue with our work.  Thanks in advance!
Userlevel 3
Thanks Dan!  This is a great update, but I cannot currently write the base data to the MDA table so I am unable to complete any calculations.  That's what I'm currently stuck on that I'm hoping Scott (or someone else from Gainsight) can help me with ASAP.
Userlevel 3
Update : our Gainsight CSM just called me to setup some time with a Solution Architect to troubleshoot our issue.  I will update this thread after our meeting.  Thanks all!
Userlevel 3
Thanks to the awesome support from Jared at Gainsight, we were able to get data flowing to our MDA table. The issue was related to incorrect settings with our Account ID mapping.  Thanks! 🙂