header
Solved

Calculated fields in Data Designer are not showing up correctly in reports

  • 25 March 2020
  • 2 replies
  • 62 views

Userlevel 3
Badge

I created a Design in Data designer that brings data from the same object (App Usage Trends) but one of them with a date filter. Essentially: Current week and previous week. I then created a calculated field that give me the difference between the current count and previous week's count. Pretty simple. I also created several other "difference fields". The sample data at the bottom shows those calculated fields properly but when used in Analyze or a report, they show up as Zero (second screen shot).

I did run the design to create a Dataspace and I get the same results in a report.

 

Has anyone seen this before?

 

My calculated fields are part of a Transform box and all look like this:

 

When I did not have “Treat null as Zero” checked, that field was coming back empty, in the report, but was showing data in the sample. Real mystery.

 

thanks!
Lyne

icon

Best answer by phani_kumar 16 September 2020, 09:24

Hi.

Tried with a similar use case in my org and below are the results with Out “treat null value as Zero”

Screenshot:

The smaple Data Preview:

 

But this is not the case if we check the “Treat null value as zero”

In this case will get the data in the calculated fields. Because we are providing a Zero value in case if there is no data in any of the Numeric fields which are used for to calculation purpose.

Screenshots:

Sample Data Preview:

 

Thanks.

View original

2 replies

Userlevel 6
Badge

Hi.

Tried with a similar use case in my org and below are the results with Out “treat null value as Zero”

Screenshot:

The smaple Data Preview:

 

But this is not the case if we check the “Treat null value as zero”

In this case will get the data in the calculated fields. Because we are providing a Zero value in case if there is no data in any of the Numeric fields which are used for to calculation purpose.

Screenshots:

Sample Data Preview:

 

Thanks.

Userlevel 7
Badge

@lyne_therien Does Phani’s post help you? This is the expected behaviour(designed to work) of the product. 

 

 

Reply