Acknowledged

Horizon Analytics feedback


Userlevel 7
Badge +2

Not sure the best way to give feedback on Horizon Analytics since I don’t believe it is technically still in Beta… so will start this thread to capture as I am kicking the tires on it.

 

  1. When I try to access Custom Colors in the new UI, I open an existing entry and the data never loads (this was done in an Incognito browser window, so it’s not cache)
  2. When drilling down into a report from a dashboard, the “Analyze Report” button should not
    appear
    for users that do not have access to Report Builder. 


    When a non-privileged user clicks that button, they get a “403 Access Denied/Forbidden” error.  This will result in numerous tickets sent to admin teams saying there is a problem or requesting access.  This should be disabled for all users that do not have access to Report Builder.
    Here are my current report builder settings: 
     

     

  3. The text that accompanies the refresh button on charts/graphs is misleading.  The example below indicates that the data was refreshed and that if you click on refresh you’ll get the latest data - but this particular graph pulls from a data table that only gets refreshed once per day.  The language here should be modified to remove the confusion.

  4. I have a chart that appears to have an unexpected item in the legend in the new UI, but it doesn’t have that in the old UI (hard to see bc of the custom colors, but there is a cream color there, the same color that matches the N/A value)
    NEW UI
    OLD UI
  5. Regarding the “You did some modifications to the dashboard. Do you want us to remember them”
    • It is more grammatically accurate to say “You made some modifications to the dashboard.” 
    • It does not respect the pinned navigator - the message gets cut off:
       
  1. Clearing a filter takes two steps now instead of one:
    New UI
     
    OLD UI
    1.  The date filter is a bit awkward in the new UI… you have to scroll to the right in order to add a second date for a custom Between statement… would be better to have the date fields stacked vertically without the need to scroll:
      NEW UI
      OLD UI

       

  1. When sharing dashboards, I am only able to pick a NXT-direct domain to share - what if the dashboard has SFDC reports on it?  We need to be able to share a link that is displayable via SFDC:

     

  2. Are there supposed to be two sharing options?

     

  3. When I share a dashboard via LINK, I get these errors when clicking through:

     
  4. Selecting the three dots on a report on the far right side of the window sometimes cuts off the options I can only see the full list when I expand the browser to Full Screen - this doesn’t happen all the time, only sporadically...

     


38 replies

Userlevel 6

@rakesh 

Userlevel 7
Badge +2

@darkknight thank you for the feedback. Your feedback is always valuable for us.

Userlevel 7
Badge

@darkknight I’ve got some related feedback here you might be interested in: 

 

Userlevel 7
Badge +2

I also have a chart that is built off of a Data Designer set that keeps giving me intermittent errors:
 

 

Userlevel 7

Hi Jeff, 

Thanks for the feedback . 

1 Custom Colors → This looks like a bug. We will look into it in detail. 
2 Drilldown Analyze → Currently its driven out of setting. You can turn it off or on. With end user reporting, this will fit in nicely where we evaluate if the user can analyze this dataset or not. 

3 This text is representative of caching. Report does not know the time of the data, it can be daily or weekly, etc. What this shows is the latest time the report hit the database and fetched the data. We are thinking of a toggle here to turn it off → I think this should solve the problem you are referring.

4 Looks like the other cream legend is null value. It looks like NA in older reporting and null values are being clubbed. We will need verify this further.

Userlevel 1

I also have a chart that is built off of a Data Designer set that keeps giving me intermittent errors:
 

 

@darkknight We have sent out a fix for this issue, can you check if you’re still facing this issue? 

Userlevel 7
Badge +2

Hi Jeff, 

Thanks for the feedback . 

1 Custom Colors → This looks like a bug. We will look into it in detail. 
2 Drilldown Analyze → Currently its driven out of setting. You can turn it off or on. With end user reporting, this will fit in nicely where we evaluate if the user can analyze this dataset or not. 

3 This text is representative of caching. Report does not know the time of the data, it can be daily or weekly, etc. What this shows is the latest time the report hit the database and fetched the data. We are thinking of a toggle here to turn it off → I think this should solve the problem you are referring.

4 Looks like the other cream legend is null value. It looks like NA in older reporting and null values are being clubbed. We will need verify this further.

Thanks Rakesh.  

#1 Need to have this resolved before we GA in Prod.

 #2 what is the setting that can be turned on/off? As noted in the post, I turned off all 3 General Settings in Report Builder and the Analyze Report persists.

#3 I understand it’s referring to caching - but the way it is worded will confuse end users. If you are not planning to have the toggle available when this GA’s in my production environment, then, before then, please change the wording so that it does not indicate that the data has been refreshed.

#4 Need to have this resolved before we GA in prod.

 

Userlevel 7
Badge +2

I also have a chart that is built off of a Data Designer set that keeps giving me intermittent errors:
 

 

@darkknight We have sent out a fix for this issue, can you check if you’re still facing this issue? 

This seems to be corrected now thank you

Userlevel 7
Badge +2

@rakesh Is the Dashboard Builder filter supposed to remain sticky?  It seems like it only remains sticky once:

 

  1. Open Dashboard Builder ; filter for something

     

  2. Select a Dashboard
  3. Exit Dashboard
  4. Filter is still sticky on the previously filtered selection.
  5. Select another Dashboard.
  6. Exit Dashboard.
  7. Sticky filter is gone.

Not a major issue, but seems like an inconsistency in the stickiness of the filter.

 

 

Userlevel 7
Badge +2

@rakesh I keep adding additional items to the main post - please let me know if that is helpful or if you want them as comments/separate posts. Thanks

Userlevel 7
Badge +2

@rakesh with regard to the fields that display in the Report List View, this should be stick.  

I will always want to have the “Used In” (and “Source Object”) in my List View, but right now when I select it ia the Settings gear, if I navigate away and come back it is gone so I have to manually select them again. 

This feels like a regression because in the current Report Builder, the “Used In” always appears by default.

 

Userlevel 1

@rakesh with regard to the fields that display in the Report List View, this should be stick.  

I will always want to have the “Used In” (and “Source Object”) in my List View, but right now when I select it ia the Settings gear, if I navigate away and come back it is gone so I have to manually select them again. 

This feels like a regression because in the current Report Builder, the “Used In” always appears by default.

 



@darkknight , We are adding support for preserving user’s preferences on the listing page in the upcoming releases. This should be handled by it.
 

Userlevel 7
Badge +2



@darkknight , We are adding support for preserving user’s preferences on the listing page in the upcoming releases. This should be handled by it.
 

 

Thanks @asrivastav

Also does not appear I can delete a Report Builder folder even though the folder is empty and has no nested folders inside it:

 

Userlevel 7
Badge +2

@asrivastav @rakesh 

For some reason when I click into a Report in Horizon Report Builder, it duplicates my Salesforce header.  This was done in an Incognito window to bypass cache: 

 

Userlevel 1



@darkknight , We are adding support for preserving user’s preferences on the listing page in the upcoming releases. This should be handled by it.
 

 

Thanks @asrivastav

Also does not appear I can delete a Report Builder folder even though the folder is empty and has no nested folders inside it:

 

 

@darkknight , Could you please check the Trash folder if it contains reports linked to this folder? We do not unlink the reports from the folder when they are moved to trash, this was done to make sure that they are restored to the same location (similar to Recycle Bin behaviour) 

 

Userlevel 7
Badge +2

@rakesh @asrivastav I’m noticing odd behavior when zooming on a bar chart.  Sometimes when I Zoom in, the top or bottom record doesn’t show a bar - even though there is data present. I assume this may be because the Zoom caught the record right in the middle of the bar, but if the chart isn’t going to show a bar, it shouldn’t show the Company name - or if it is going to show the Company Name, it should show the bar:

FIRST ZOOM
SECOND ZOOM

 

Userlevel 7
Badge +2

 

@darkknight , Could you please check the Trash folder if it contains reports linked to this folder? We do not unlink the reports from the folder when they are moved to trash, this was done to make sure that they are restored to the same location (similar to Recycle Bin behaviour) 

 

Ah yes the trash folder! Thank you (That is going to take some getting used to).  Any chance a “select all” option is coming to the Trash folder anytime soon?

Userlevel 1

Ah yes the trash folder! Thank you (That is going to take some getting used to).  Any chance a “select all” option is coming to the Trash folder anytime soon?

@rakesh fyi :nerd:

Userlevel 7
Badge +2

@rakesh @asrivastav 

 

Can we please make the default Null color something darker?  The cream color doesn’t show up well against the white dashboards. 

Also, include a “No Value” label on the legend instead of no label at all:

 

Userlevel 7
Badge +2

@rakesh @asrivastav  Legends should display in Alpha-Numeric order consistently by default.  Most of these reports in the screenshot below come from the same data designer table, yet the legends display in inconsistent orders in the Horizon UI.  Just makes the design appear haphazard

 

NEW UI.

But in the OLD UI, they display in a consistent order (albeit in reverse Alpha-Numeric):

OLD UI

 

Userlevel 7
Badge +2

@rakesh When I have bar chart labels turned on, and I click on one of the legend items to only show the specific legend item, all the labels remain:

 

Userlevel 7
Badge +2

@rakesh Why are charts that used to have no trouble displaying in the current UI now suddenly producing message “Unable to display the chart. The data is too granular for the visualization. Add more filters or try other visualization options.”?

This doesn’t seem to make sense… if it could load before, why can’t it load now? (Examples below)

This is problematic because frequently we have reports that are intentionally not filtered down very far so that Dashboard Filters can be applied to reduce the volume displayed.  Now, I have no way of making changes to those reports in Report Builder unless I temporarily add a bogus filter to reduce the data enough to make the changes, then I have to remember to remove the temporary filter.  It’s increases the amount of effort to tweak reports that live on dashboards and a big departure from the current UI experience

If the OLD UI could do it, the NEW UI should be able to do it too.

NEW UI - SAME FILTER LOGIC AS OLD UI
OLD UI - SAME FILTER LOGIC AS NEW UI

 

Userlevel 7
Badge +2

When I have Advanced Logic on report filters, and I go to add another filter, it incorrectly sets the logic. See example below.  The “J” was outside the last set of brackets.  When I attempted to add a new filter, it automatically inserted “J” AND “K” into the last set of brackets, when they should have remained outside the last set of brackets:

 

Userlevel 1

@darkknight Regarding point number 10, When I share a dashboard via LINK, I get these errors when clicking through

Can you please confirm the timezone of the user (sender) ?

Userlevel 7
Badge +2

@asrivastav Central US

Reply